Felsöka Commerce Data Exchange (CDX)

Sammanfattning

Den här artikeln hjälper dig att felsöka vanliga CDX-fel ( Commerce Data Exchange ) i Microsoft Dynamics 365 Commerce. Den omfattar problem med batchbearbetning på sidan Distributionsschema , fel vid nedladdning och uppladdning av sessioner, fel med datatrunkering och långsam inkrementell datasynkronisering när du har lagt till nya kanaler. Varje avsnitt innehåller symtom, möjliga orsaker och rekommenderade lösningar.

"Kör nu" öppnar batchbearbetning på sidan Distributionsschema

Symptoms

Kommandot Kör nu på sidan Distributionsschema öppnar formuläret för att skapa batchen i stället för att köra jobbet direkt.

Skärmbild av sidan Distributionsschema som visar att batchbearbetning är aktiverat.

Orsak

Körning av datasynkroniseringsjobb i den interaktiva AOS-instansen påverkade prestandan för användare i alla Finance & Operations-formulär. De här jobben körs nu endast i Batch-AOS.

Lösning

Vi rekommenderar att du inte ändrar det här beteendet i en produktionsmiljö. Men om du befinner dig i en utvecklingsmiljö kan du ändra det här beteendet i Commerce-huvudkontoret:

  1. Gå till Delade handelsparametrar>Konfigurationsparametrar.
  2. Ange en ny parameter som heter CDX_DISABLE_FORCESCHEDULEINBATCH och har värdet 1.

Fel som orsakas av sträng- eller binärdata trunkerade i tabellen

Symptoms

Du får ett felmeddelande som anger att en nedladdnings- eller uppladdningssession har gett upphov till något av följande fel:

Microsoft.Dynamics.Retail.CommerceDataExchange.ProcessDataPackageException Microsoft.Dynamics.Retail.CommerceDataExchange.BulkCopyDataException System.InvalidOperationException (sträng- eller binärdata är trunkerade i tabellen)

Orsak

Data i källdatabasen är större än kolumnen i måldatabasen. Det här problemet uppstår vanligtvis när du utökar en sträng utökad datatyp (EDT) i Finance &Operations till en större längd eftersom den ändringen inte speglas automatiskt i kanaldatabasen.

Lösning

Metodtips finns i Aktivera anpassad synkronisering av Commerce Data Exchange via tillägg. Överväg att ta bort EDT-tillägget i tabellfältet som du redigerar. Överväg också att använda CDX-tilläggstabellen för att lagra det fullständiga värdet i stället.

Om problemet kvarstår skapar du en Microsoft-supportbegäran. Mer information finns i Hämta support.

Inkrementell datasynkronisering (delta) tar för lång tid

Symptoms

Inkrementell datasynkronisering (delta) tar för lång tid, även om antalet berörda rader är litet. Du kan uppleva en liknande prestandapåverkan om du skapar en tillfällig kanaldatabasgrupp eller kör en fullständig synkronisering.

Orsak

Det här problemet kan inträffa om du lägger till en ny kanal (arkiv) eftersom systemet måste återskapa alla data för det nya arkivet.

Lösning

Datasynkroniseringslogik har förbättrats i de senaste versionerna. Om du planerar att lägga till kanaler regelbundet kan du ge tillräckligt med tid för att den första inkrementella synkroniseringen ska slutföras efter att du har lagt till en kanal innan data behövs i skalningsenheterna.

Fel vid nedladdning av sessionspaket eftersom posten inte hittades

Symptoms

När du försöker ladda ned ett datapaket från sidan Ladda ned sessioner i Commerce-huvudkontoret får du följande felmeddelande:

Post för Id – <Nummer> hittades inte.

Orsak

Lagringsbevarandeprincipen tog bort det underliggande datapaketet. Den relaterade nedladdningssessionen är förmodligen för gammal och en fullständig synkronisering kan vara nödvändig.

Lösning

Skapa en Microsoft-supportbegäran. Mer information finns i Hämta support.

Nedladdnings- och uppladdningssessioner saknas

Symptoms

Inga nedladdningssessioner tillämpas och inga uppladdningssessioner skapas.

Orsak

Orsaken beror på typen av skalningsenhet:

  • Molnskalningsenhet (CSU): CSU-distributionen i Power Platform-administrationscentret kan misslyckas och CSU avregistreras från datasynkroniseringens molntjänst.
  • Lokal skalningsenhet: Async-klienttjänsten på Windows-servern kanske inte körs korrekt.
  • Store Commerce-app: Appen kanske inte körs eller så är offlineläget kanske inte konfigurerat.

Anmärkning

Oavsett orsaken till problemet går du till Kanaldatabas>datasynkronisering>Senaste anslutning för att kontrollera när en datasynkroniseringshändelse senast inträffade.

Lösning

Följ dessa steg baserat på typen av skalningsenhet:

  • Molnskalningsenhet: Ominstallera CSU med hjälp av administrationscentret för Power Platform.
  • Lokal skalningsenhet: Kontrollera status och händelser för Async-klienttjänsten på Windows-servern.
  • Store Commerce-app: Kontrollera att appen körs och att offlineläget har konfigurerats i vyn Databasanslutningsstatus .

Om problemet kvarstår skapar du en Microsoft-supportbegäran. Mer information finns i Hämta support.